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Introduction

Target Audience

This guide is designed for system administrators planning to administer 
Adobe® Acrobat® 9 Pro with the Casper Suite.
 

What’s in This Guide

Each chapter in this guide provides step-by-step instructions on how to 
perform a different administrative task with the Casper Suite:

”Deploying Acrobat 9 Pro,” explains the serialization scenarios you need to 
consider before deploying Acrobat 9 Pro. It also provides instructions on how 
to package the Acrobat 9 Pro Installer for deployment, upload it to the JSS, and 
deploy it using any one of the three available methods. 

“Reporting on Acrobat 9 Pro,” explains how to track and generate reports on 
licensing and application information.  

“Updating Acrobat 9 Pro,” explains how to package and deploy an Acrobat 9 
Pro update. 
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Overview

One of the most difficult aspects of administering Adobe® Acrobat® 9 Pro 
on the Mac platform is managing serialization (or licensing) of the product. 
Deploying a serialized installation or update package of Acrobat 9 Pro without 
first considering several environmental factors can jeopardize the serialization 
of existing Adobe products. 

In addition to providing initial deployment and update deployment solutions 
for both serialized and un-serialized packages, the Casper Suite’s reporting 
capabilities allow you to more effectively track serialization of the software.  
Viewing the serialization of Acrobat 9 Pro as deployed in your environment can 
help you quickly determine which clients need to receive a serialized or an un-
serialized update. 

This technical paper provides a complete workflow for deploying, reporting 
on, and updating Acrobat 9 Pro with consideration to the challenges of 
serialization. 
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The following components are required to complete the instructions in this 
guide: 

•	 Casper Suite v7.31 or later running in your environment
•	 Adobe Acrobat 9 Pro installer media
•	 (Optional) Adobe Acrobat 9 Pro updater
•	 Composer application
•	 Casper Admin application
•	 Access to the JAMF Software Server (JSS)

 

Important Concepts

This guide refers to the following Casper Suite concepts:

•	 Package management
•	 Remote deployment (using policies and Casper Remote)
•	 Imaging
•	 Licensed software capabilities
•	 Application reporting
•	 Smart computer groups

You can learn more about these concepts in the Casper Suite Administrator’s 
Guide, available at http://jamfsoftware.com/libraries/pdf/products/
documentation/Casper_Suite_7.3_Documentation.pdf.

Requirements

http://jamfsoftware.com/libraries/pdf/products/documentation/Casper_Suite_7.3_Documentation.pdf
http://jamfsoftware.com/libraries/pdf/products/documentation/Casper_Suite_7.3_Documentation.pdf
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Deploying Acrobat 9 Pro

Before You Begin

Before deploying Acrobat 9 Pro, it is important take into account whether 
other Adobe products are installed in your environment. Consider the 
following scenarios:

•	 Deploying Acrobat 9 Pro to clients that have Adobe products installed. 
In this case, it is recommended that you deploy an un-serialized (or 
unlicensed) version of Acrobat 9 Pro. This prevents the serialization for any 
installed Adobe products from being overwritten. Attempting to deploy 
a serialized (or licensed) version of Acrobat 9 Pro without first removing 
existing Adobe products will cause the serialization of the existing products 
to be overwritten.   
 
If you need to deploy a serialized version of Acrobat 9 Pro in this scenario, 
remove the existing Adobe products and redeploy them along with 
Acrobat 9 Pro. When doing this, make sure that Acrobat 9 Pro is installed 
before the other products to prevent an overwrite of the licensing files.  
 
To ensure that Acrobat 9 Pro is installed first, assign the Acrobat 9 Pro 
package a priority of “9” when you upload and configure the package 
using the Casper Admin application. (For more information on assigning 
priorities, see the “Changing Package Attributes” section in the Casper 
Suite Administrator’s Guide.) 

•	 Deploying Acrobat 9 Pro to clients that do not have Adobe products 
installed. In this case, it is recommended that you serialize Acrobat 9 Pro 
prior to deployment. If you do not serialize the product, it remains un-
serialized on the client as a 30-day trial.  
 
To serialize Acrobat 9 Pro after is it deployed, an administrator or end user 
must manually enter the serial number from the client.

After determining which scenario best describes your environment, you can 
deploy Acrobat 9 Pro by following a few simple steps:  

1.	 Create a un-serialized or serialized package of Acrobat 9 Pro. 
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2.	 Upload the Acrobat 9 Pro DMG to the JSS. 

3.	 Deploy the Acrobat 9 Pro DMG remotely, at imaging time, or using the Self 
Service application. 

Note: The instructions in this section apply to Acrobat 9 Pro only. For 
instructions on deploying other Adobe® Creative Suite® 5 (CS5) products, 
see the Simplifying Adobe Creative Suite 5 Administration with the Casper Suite 
technical paper.

Packaging the Acrobat 9 Pro Installer

The first step to deploying Acrobat 9 Pro is to install the software on an admin 
computer and create a DMG-style package using the Composer application.

1.	 Install Acrobat 9 Pro.    

2.	 When the Adobe Acrobat 9 Pro Setup Assistant appears, specify whether 
you want to create a serialized or un-serialized package: 
 
To create a serialized package, select I have a serial number for this 
product, enter the serial number, and then click Next to complete rest of 
the Setup Assistant.  
 
To create an un-serialized package, select I’d like to use this product on a 
trial-basis, and then click Next to complete rest of the Setup Assistant.  
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3.	 After completing the Setup Assistant, choose Help > Check for Updates 
and click Yes. This applies all available updates to the software. 

4.	 Open Composer. 

5.	 Choose File > Download Latest Diffs to download the latest diff files from 
JAMF Software.  

6.	 When the download is complete, click the New Package button in the 
toolbar. 

7.	 Select Software in the sidebar. 

8.	 Select the icon for Acrobat 9 Pro in the New Package pane and click 
Choose to build the package source.  

9.	 When the package source appears in the sidebar, click Build as DMG to 
build the package.

 

Uploading the Acrobat 9 Pro DMG

You can now upload the Acrobat 9 Pro DMG to the JSS using the Casper Admin 
application.  

1.	 Open Casper Admim.  

2.	 Drag the Acrobat 9 Pro DMG from the Finder into Casper Admin.  
It may take a few minutes to upload depending on the size of the file. 

3.	 Select the Acrobat 9 Pro DMG in the list of packages and click the Info 
button in the toolbar.  
The DMG name is displayed in blue because does not yet belong to a 
category. 

4.	 Click the Info tab and assign a category. 

5.	 Click the Options tab and assign a priority.  
The recommended priority for Acrobat DMGs is “9”. This ensures that 
Acrobat 9 Pro is deployed before other Adobe packages. For more 
information on choosing priorities, see the “Changing Package Attributes” 
section in the Casper Suite Administrator’s Guide. 

6.	 Configure additional settings as needed and click the OK button.  

7.	 Type Command + S to save your changes, and then quit the application.
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Deploying the Acrobat 9 Pro DMG

There are several deployment scenarios that you can choose from: 

•	 Remote deployment, using a policy or Casper Remote
•	 Deployment at imaging time
•	 Client-side installation via the Self Service application (This allows end users 

to install the software using an iTunes-like interface.)

Deploying Acrobat 9 Pro remotely or at imaging time automatically updates 
client inventory reports in the JSS to reflect the new software. 
  

To deploy the Acrobat 9 Pro DMG using a policy:

1.	 Log in to the JSS.

2.	 Click the Management tab.

3.	 Click the Policies link.

4.	 Click the Create Policy button in the toolbar. 

5.	 Make sure that the Install or uninstall a package option is selected and 
click Continue. 

6.	 Follow the onscreen instructions to configure the rest of the policy.

 
To deploy the Acrobat 9 Pro DMG using Casper Remote:  

1.	 Open Casper Remote. 

2.	 In the Computers list, select the checkbox next to the clients you want to 
receive the deployment.  

3.	 Click the Packages tab and select the checkbox next to the Acrobat 9 Pro 
DMG. 

4.	 Click Go.

To deploy the Acrobat 9 Pro DMG at imaging time:

1.	 Open Casper Admin. 
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2.	 Drag the Acrobat 9 Pro DMG from the package repository to the imaging 
configuration in the sidebar. 

3.	 Type Command + S to save your changes, and then quit the application.

To deploy the Acrobat 9 Pro DMG using Self Service:

See the “Making Policies Available Through Self Service” section in the Casper 
Suite Administrator’s Guide.
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After deploying Acrobat 9 Pro, you can track licensing and version information 
by generating two kinds of reports: Licensed Software reports and Application 
reports. Viewing these reports can help you better comply with Adobe 
licensing policies and determine which clients need to receive updates.

Generating accurate reports involves a few simple steps: 

1.	 Create a licensed software record to store licensing information in the JSS. 

2.	 Update client inventory records to ensure that accurate information is 
reflected in the reports. 

3.	 Generate the reports to view licensing, version, and deployment 
information across your environment.  

Creating a Licensed Software Record

Create a licensed software record using the Acrobat 9 Pro template in the JSS. 

1.	 Log in to the JSS. 

2.	 Click the Settings tab. 

3.	 Click the Licensed Software Management link. 

4.	 Click the Licensed Software from Template button in the toolbar. 

5.	 Click the Create link across from the “Adobe Acrobat 9.0 Professional” 
template. 

6.	 Click the Licenses tab. 

7.	  Click the Add License link. 
 
 
 

Reporting on Acrobat 9 Pro
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8.	 Enter the serial number for the product and specify the number of licenses 
owned by your organization.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

9.	 Click the Store License button. 

10.  Click the Software Definitions tab and verify that “Acrobat 9 Pro.app” is in
        the list of applications.

11.  Click Save. 
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Updating Inventory 

The quickest way to update client inventory in the JSS is to use the Casper 
Remote application. This allows you to update inventory on the fly.

1.	 Open Casper Remote. 

2.	 In the Computers list, select the checkbox next the clients that have 
Acrobat 9 Pro installed.  

3.	 Click the Advanced tab and select the Update Inventory checkbox. 

4.	 Click the Go button.

Generating a Licensed Software Report

Licensed Software reports let you track the license usage for a piece of 
software across your environment. You can view the following information in 
these reports:  

•	 Number of licenses owned by your organization
•	 Number of licenses in use
•	 Clients to which the licenses are deployed

1.	 Click the Inventory tab in the JSS. 

2.	 Click the Licensing link above the search field. 

3.	 Leave the search field blank and click the Search Licensing button, or type 
the Enter key. 

Generating an Application Report

Application reports display the following information about Acrobat 9 Pro as 
deployed in your environment:

•	 Version number
•	 Number of copies deployed

1.	 Click the Applications link above the search field. 

2.	 Type the name of the application you want to view information for. 

3.	 Click the Search Applications button, or type the Enter key. 
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As with initial deployments of Acrobat 9 Pro, updates require special 
consideration. 

There are two ways to update Acrobat 9 Pro: 

•	 Deploy a fully-updated package of the latest Acrobat 9 Pro installer as 
described in the “Deploying Acrobat 9 Pro “ section of this document. Use 
this method if: 

-- Acrobat 9 Pro is not yet installed in your environment.
-- There are different versions of Acrobat 9 Pro installed in your 

environment. 

•	 Deploy an un-serialized package of an Adobe 9 Pro update as described 
in this section. Use this method if multiple copies of the same version of 
Acrobat 9 Pro are installed in your environment. 

Acrobat 9 Pro updates can be downloaded from Adobe’s website at http://
www.adobe.com/downloads/updates/ or accessed by launching an installer 
and navigating to Help > Check for Updates.

Packaging an Acrobat 9 Pro Update 

The following example explains how to package an un-serialized Acrobat 9.3.4 
Pro update for deployment.  

1.	 Start by installing Acrobat 9 Pro on a computer that has no other Adobe 
products installed.  

2.	 When the Adobe Acrobat 9 Pro Setup Assistant appears, select I’d like to 
use this product on a trial-basis, and then click Next to complete rest of 
the Setup Assistant.  
 
Important: Do not apply available updates at this point. This will be done 
in step 8. 

3.	 After completing the Setup Assistant, open Composer.

Updating Acrobat 9 Pro

http://www.adobe.com/downloads/updates/
http://www.adobe.com/downloads/updates/
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4.	 Click the New Package button in the toolbar. 

5.	  Select New and Modified Snapshot in the New Package pane and click 
Choose. 

6.	 Specify a name for the package (for example, “Acrobat 9.3.4 Pro Full 
Update”) and click Begin to initiate the initial snapshot. 

7.	 When the snapshot is complete, open the copy of Acrobat 9 Pro you 
installed in step 1. 

8.	 Choose Help > Check for Updates and click Yes. This applies all available 
updates to the software. 

9.	 When the update is complete, click the Build Package button in 
Composer. 

10.  When the package source appears in the sidebar, use the Library folder
        in Composer to navigate to /Library/Application Support/Adobe/
        AdobePCD and delete the AdobePCD file. 
        If this file does not exist, move on to the next step. 

11.  Click the Build as DMG button in Composer to build the Acrobat Update
        DMG. 
 

Uploading the Acrobat Update DMG 

You can now upload the Acrobat Update DMG to the JSS using the Casper 
Admin application. 

1.	 Open Casper Admin.  

2.	 Drag the Acrobat Update DMG from the Finder into Casper Admin.  
It may take a few minutes to upload depending on the size of the file. 

3.	 Select the Acrobat Update DMG in the list of packages and click the Info 
button in the toolbar.  
The DMG name is displayed in blue because does not yet belong to a 
category. 

4.	 Click the Info tab and assign a category. 
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Click the Options tab and assign a priority.  
The recommended priority for updates is “11”. This ensures that updates 
are deployed after installers. For more information on choosing priorities, 
see the “Changing Package Attributes” section in the Casper Suite 
Administrator’s Guide. 

5.	 Configure additional settings as needed and click the OK button.  

6.	 Type Command + S to save your changes, and then quit the application.

Creating a Smart Computer Group 

Next, create a smart computer group based on clients that are not running 
Acrobat 9.3.4 Pro.  This group will be used to scope the update deployment in 
the “Deploying the Acrobat Update DMG” section of this document.

1.	 Log in to the JSS. 

2.	 Click the Management tab. 

3.	 Click the Smart Computer Groups link. 

4.	 Click the Create Smart Group button in the toolbar. 

5.	 Specify a name for the group. For example, “Acrobat Pro Needs Updates”. 

6.	 Locate Software Information in the list of categories and click the Add (+) 
button next to it. 
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7.	 Click Application Title in the list of items.  

8.	 Type “Adobe Acrobat Pro.app” in the Criteria field. 

9.	 Click the Add (+) button next to Software Information again and click 
Application Version in the list of items. 

10.  Select “Like” from the Search Type pop-up menu. 

11.  Type “9.3” in the Criteria field. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

12.  Click the Add (+) button next to Software Information again and click
        Application Version in the list of items. 

13.  Select “Is Not” from the Search Type pop-up menu. 

14.  Type “9.3.4” in the Criteria field. 
 
15.  Click Save.
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Deploying the Acrobat Update DMG 

Acrobat 9 Pro updates can be deployed in several ways: 

•	 Remotely using a policy
•	 At imaging time
•	 Using the Self Service application 

If you are using a policy to deploy the update, scope it to the smart computer 
group that you created in the previous section. This ensures that all clients with 
Acrobat 9.3 installed receive the update. 

To deploy the Acrobat Update DMG using a policy:  

1.	 Click the Management tab in the JSS.  

2.	 Click the Policies link.  

3.	 Click the Create Policy button in the toolbar. 

4.	 Make sure that the Install or uninstall a package option is selected and 
click Continue. 

5.	 Follow the onscreen instructions to configure the rest of the policy. 

To deploy the Acrobat Update DMG at imaging time: 

1.	 Open Casper Admin. 

2.	 Drag the Acrobat Update DMG from the package repository to the imaging 
configuration in the sidebar. 

3.	 Type Command + S to save your changes, and then quit the application.

To deploy the Acrobat Update DMG using Self Service:

See the “Making Policies Available Through Self Service” section in the Casper 
Suite Administrator’s Guide.
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Useful Links on Related Topics

JAMF Software Links

For more information on JAMF Software and the Casper Suite, visit the JAMF 
Software website at http://www.jamfsoftware.com.
 
For information on administering Adobe CS5 with the Casper Suite, see the 
Simplifying Adobe Creative Suite 5 Administration with the Casper Suite technical 
paper at http://jamfsoftware.com/libraries/pdf/white_papers/Simplifying-
Adobe-CS5-Administration-with-the-Casper-Suite.pdf.

 
Adobe Links

For more information on Acrobat 9 Pro, visit Adobe’s website at http://www.
adobe.com/products/acrobatpro/.

http://www.jamfsoftware.com
http://jamfsoftware.com/libraries/pdf/white_papers/Simplifying-Adobe-CS5-Administration-with-the-Casper-Suite.pdf
http://jamfsoftware.com/libraries/pdf/white_papers/Simplifying-Adobe-CS5-Administration-with-the-Casper-Suite.pdf
http://www.adobe.com/products/acrobatpro/
http://www.adobe.com/products/acrobatpro/
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